Go Back   Ohio Bimmers forum > Ohio Bimmers > General BMW Chat

Reply
 
Thread Tools Display Modes
Old 12-28-2015, 11:47 AM   #1
jey4175
Newb
 
Join Date: Dec 2015
Name: Silvian
Location: New Albany
Car: 2008 X5 4.8i
Posts: 13
jey4175 is on a distinguished road
Default Belt squeak on cold starts..

Is anyone available to take a look or if you know of any reasonable mechanics, please let me know. I'd be more than happy to make your time worthwhile. Thanks !

Zip code - 43054
2008 BMW X5 4.8i


Sent from my iPhone using Tapatalk
jey4175 is offline   Reply With Quote
Old 12-28-2015, 12:24 PM   #2
MrBillyTalent
<
OB Supporter
 
MrBillyTalent's Avatar
 
Join Date: May 2009
Name: Nunya
Location: Toledo OH
Car: e34, e36, e46, e90
Posts: 1,801
MrBillyTalent is on a distinguished road
Default

Consider a new belt or maybe a pulley, I'm not wise enough to distinguish the difference in the noises
MrBillyTalent is offline   Reply With Quote
Old 12-28-2015, 12:35 PM   #3
jey4175
Newb
 
Join Date: Dec 2015
Name: Silvian
Location: New Albany
Car: 2008 X5 4.8i
Posts: 13
jey4175 is on a distinguished road
Default

Thanks !


Sent from my iPhone using Tapatalk
jey4175 is offline   Reply With Quote
Old 01-10-2016, 10:37 AM   #4
justacarguy
Target Acquired
OB Supporter
 
justacarguy's Avatar
 
Join Date: Aug 2010
Name: Marshall
Location: Canal Winchester
Car: 01 330I
Posts: 202
justacarguy is on a distinguished road
Default

Sounds like my 330 did when the alternator pulley was shot, start cheap with the belt and then look more into pulleys if that doesn't fix it, you recently bought it so a new belt will give piece of mind and maybe fix the issue. if not the pulleys are easy to change and I will help you with it if you want
justacarguy is offline   Reply With Quote
Old 01-10-2016, 10:44 AM   #5
jey4175
Newb
 
Join Date: Dec 2015
Name: Silvian
Location: New Albany
Car: 2008 X5 4.8i
Posts: 13
jey4175 is on a distinguished road
Default

@justacarguy, thanks again. I sent you a PM..


Sent from my iPhone using Tapatalk
jey4175 is offline   Reply With Quote
Old 01-10-2016, 07:11 PM   #6
Moete87
OHIO STATE
 
Moete87's Avatar
 
Join Date: Aug 2009
Location: Cincinnati
Car: 135i
Posts: 301
Moete87 is on a distinguished road
Default

My 135i did the same thing. I had the pully and belt replaced since it was still the OEM belt at 65k miles and I wanted to get it all done without having to worry about it. But the pully was the issue so it was replaced.
__________________
Current: 2011 BMW 335xi Sedan / Alpine White / Black Leather / PPK 2 / BMW Performance Exhaust & BMW Tune / M Package / Carbon bits in a few places..
Moete87 is offline   Reply With Quote
Old 01-10-2016, 10:01 PM   #7
jey4175
Newb
 
Join Date: Dec 2015
Name: Silvian
Location: New Albany
Car: 2008 X5 4.8i
Posts: 13
jey4175 is on a distinguished road
Default

Thanks for the info..


Sent from my iPhone using Tapatalk
jey4175 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



Google+
All times are GMT -4. The time now is 08:12 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
OhioBimmers.com is in no way sponsored, endorsed or affiliated by or with BMW NA / BMW AG or any of it's subsidiaries or vendors.
BMW is a registered trademarks of BMW AG.
Copyright © 2008 - Present , OhioBimmers.com